dump-ecl: Defeat ASDF's magic internal knowledge of itself.
[runlisp] / debian / rules
index 99b8a03..9b128d0 100755 (executable)
@@ -1,38 +1,16 @@
 #! /usr/bin/make -f
 
-build:
-       rm -rf build deb-build
-       mkdir deb-build
-       cd deb-build; ../configure --prefix=/usr --infodir=/usr/share/info
-       make -C deb-build
-       touch build
+DH_OPTIONS              = --parallel -Bdebian/build
 
-install: build
-       dh_clean
-       make -C deb-build install DESTDIR=`pwd`/debian/tmp
+OVERRIDES              += auto_configure
+dh_auto_configure_OPTS  = --
+dh_auto_configure_OPTS += --with-imagedir=/var/lib/runlisp
 
-binary-indep: install
-       dh_testdir -i
-       dh_testroot -i
-       dh_installinfo -i common.info
-       dh_compress -i
-       dh_installdocs -i
-       dh_gencontrol -i
-       dh_fixperms -i
-       dh_installdeb -i
-       dh_md5sums -i
-       dh_builddeb -i
+OVERRIDES              += auto_install
+dh_auto_install_OPTS    = --destdir=debian/tmp
 
-binary-arch:
+%:; dh $@ $(DH_OPTIONS)
 
-binary: binary-indep binary-arch
-
-source:
-       rm -rf deb-build/*.tar.gz deb-build/=deb=
-       make -C deb-build dist
-       mkdir deb-build/=deb=
-       cd deb-build/=deb=; tar xvfz ../*.tar.gz
-       d=`pwd`; cd ..; dpkg-source -i -b $$d/deb-build/=deb=/*
-       rm -rf deb-build/=deb=
-
-.PHONY: binary binary-arch binary-indep clean install source 
+$(foreach o, $(sort $(OVERRIDES)), dh-$o-hook)::; @:
+$(foreach o, $(sort $(OVERRIDES)), override_dh_$o): override_dh_%: dh-%-hook
+       dh_$* $(addprefix -O, $(DH_OPTIONS)) $(dh_$*_OPTS)