dump-ecl: Defeat ASDF's magic internal knowledge of itself.
[runlisp] / debian / rules
index da79b9e..9b128d0 100755 (executable)
@@ -1,7 +1,16 @@
 #! /usr/bin/make -f
 
-CDBS = /usr/share/cdbs/1
-include $(CDBS)/rules/debhelper.mk
-include $(CDBS)/class/autotools.mk
+DH_OPTIONS              = --parallel -Bdebian/build
 
-DEB_BUILDDIR = build
+OVERRIDES              += auto_configure
+dh_auto_configure_OPTS  = --
+dh_auto_configure_OPTS += --with-imagedir=/var/lib/runlisp
+
+OVERRIDES              += auto_install
+dh_auto_install_OPTS    = --destdir=debian/tmp
+
+%:; dh $@ $(DH_OPTIONS)
+
+$(foreach o, $(sort $(OVERRIDES)), dh-$o-hook)::; @:
+$(foreach o, $(sort $(OVERRIDES)), override_dh_$o): override_dh_%: dh-%-hook
+       dh_$* $(addprefix -O, $(DH_OPTIONS)) $(dh_$*_OPTS)