debian, Makefile: Switch to Debhelper 8, and fix.
[rocl] / debian / rules
index b837317..b650542 100755 (executable)
@@ -1,44 +1,9 @@
 #! /usr/bin/make -f
 
-export DH_COMPAT = 4
+%:; dh $@ -Bdebian/build --parallel
 
-build:
-       rm -f build
-       make INCLUDES=-I/usr/include/tcl prefix=/usr
-       touch build
+override_dh_auto_build:
+       make prefix=/usr
 
-clean:
-       dh_clean
-       make clean
-       rm -f build
-
-install: build
-       dh_clean
+override_dh_auto_install:
        make install prefix=/usr INST=`pwd`/debian/rocl
-
-binary-arch: install
-       dh_testdir -a
-       dh_testroot -a
-       dh_installdocs -a README
-       dh_compress -a
-       dh_strip -a
-       dh_shlibdeps -a
-       dh_gencontrol -a
-       dh_fixperms -a
-       dh_installdeb -a
-       dh_md5sums -a
-       dh_builddeb -a
-
-binary-indep:
-
-binary: binary-indep binary-arch
-
-source:
-       rm -rf =inst=
-       mkdir -p =inst=/=deb=
-       make dist INST==inst=/
-       cd =inst=/=deb=; tar xvfz ../*.tar.gz
-       d=`pwd`; cd ..; dpkg-source -i -b $$d/=inst=/=deb=/*
-       rm -rf =inst=
-
-.PHONY: binary binary-arch binary-indep clean install source