Support Python 2.6, and switch to CDBS.
[python-cdb] / debian / rules
index 2f88883..d340b2e 100755 (executable)
@@ -1,54 +1,9 @@
 #!/usr/bin/make -f
 
-export DH_COMPAT=3
+CDBS = /usr/share/cdbs/1
 
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       touch configure-stamp
+DEB_PYTHON_SYSTEM = pycentral
+include $(CDBS)/rules/debhelper.mk
+include $(CDBS)/class/python-distutils.mk
 
-build: configure-stamp build-stamp
-build-stamp:
-       dh_testdir
-
-       python2.3 setup.py build
-
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp configure-stamp
-
-       rm -rf build dist
-
-       dh_clean
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs
-
-       python2.3 setup.py install --prefix=debian/python-cdb/usr
-
-binary-indep: build install
-
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installdocs
-       dh_installchangelogs ChangeLog
-       dh_link
-       dh_python
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+###----- That's all, folks --------------------------------------------------