debian/rules: Use old-fashioned `dpkg-buildflags' options.
[preload-hacks] / debian / rules
index cade6f7..d780d0e 100755 (executable)
@@ -1,8 +1,9 @@
 #! /usr/bin/make -f
 
-%:; dh $@ --parallel
+DH_OPTIONS              = --parallel -Bdebian/build
 
-override_dh_auto_install:
-       dh_auto_install --parallel -- \
-               prefix=/usr mandir=/usr/share/man \
-               DESTDIR=debian/tmp
+%:; dh $@ $(DH_OPTIONS)
+
+override_dh_auto_configure:
+       dh_auto_configure $(DH_OPTIONS) -- \
+               $(shell dpkg-buildflags --export=configure)