sema: New program for hacking with semaphores.
[misc] / debian / control
index ca71652..428958e 100644 (file)
@@ -1,25 +1,28 @@
-Source: nsict-utils
+Source: distorted-utils
 Section: utils
 Priority: extra
 Maintainer: Mark Wooding <mdw@distorted.org.uk>
-Build-Depends: tinycdb, cdbs, python, python-cdb,
- catacomb-dev (>= 2.1.1), mlib-dev (>= 2.0.4), libspamc-dev, libcdb-dev
+Build-Depends: debhelper (>= 9), pkg-config,
+ libcdb-dev, mlib-dev (>= 2.0.4), catacomb-dev (>= 2.1.1),
+ python, python-cdb,
+ tclsh
 Standards-Version: 3.1.1
 
-Package: nsict-utils
+Package: distorted-utils
 Architecture: all
 Section: utils
+Replaces: nsict-utils (<< 1.4.0~)
+Breaks: nsict-utils (<< 1.4.0~)
 Depends:
        mdwopt-perl,
-       nsict-cdb,
+       distorted-cdb,
        locking,
-       qmail-checkspam,
-       nsict-mail,
+       distorted-mail,
        if-mtu,
        shadowfix,
        zz,
        gorp,
-       timeout,
+       mtimeout,
        splitconf,
        xtitle,
        pause,
@@ -28,45 +31,70 @@ Depends:
        inplace,
        stamp,
        space,
-       getpass
+       getpass,
+       hush,
+       with-umask,
+       sshsvc-mkauthkeys
 Description: Dummy package for convenience.
 
+Package: nsict-utils
+Architecture: all
+Section: oldlibs
+Depends: distorted-utils
+Description: Dummy package for transition.
+ This is a transitional dummy package.  It can safely be removed.
+
 Package: mdwopt-perl
 Architecture: all
 Section: perl
 Depends: perl5
 Description: Options parser library for perl.
 
-Package: nsict-cdb
+Package: distorted-cdb
 Architecture: any
 Section: utils
+Replaces: nsict-cdb (<< 1.4.0~)
+Breaks: nsict-cdb (<< 1.4.0~)
 Depends: ${shlibs:Depends}, python (>= 2.4), python-cdb
 Description: Simple utilities for messing with CDB files.
 
-Package: timeout
+Package: nsict-cdb
+Architecture: all
+Section: oldlibs
+Depends: distorted-cdb
+Description: Dummy package for transition.
+ This is a transitional dummy package.  It can safely be removed.
+
+Package: mtimeout
 Architecture: any
 Section: utils
 Depends: ${shlibs:Depends}
 Description: Run a program for at most a given amount of time.
 
+Package: prlimit
+Architecture: linux-any
+Section: utils
+Depends: ${shlibs:Depends}
+Description: Run a program for at most a given amount of time.
+
 Package: locking
 Architecture: any
 Section: utils
 Depends: ${shlibs:Depends}
 Description: Run a program while holding a file lock.
 
-Package: qmail-checkspam
-Architecture: any
+Package: distorted-mail
+Architecture: all
 Section: mail
-Depends: ${shlibs:Depends}, qmail
-Suggests: spamassassin
-Description: Check mail for spamminess before queueing it.
+Depends: ${shlibs:Depends}, qmail, distorted-cdb, perl5, libmime-perl
+Description: Some simple scripts for mail handling.
 
 Package: nsict-mail
 Architecture: all
-Section: mail
-Depends: qmail, nsict-cdb, perl5, libmime-perl
-Description: Some simple scripts for mail handling.
+Section: oldlibs
+Depends: distorted-mail
+Description: Dummy package for transition.
+ This is a transitional dummy package.  It can safely be removed.
 
 Package: if-mtu
 Architecture: any
@@ -115,6 +143,11 @@ Architecture: all
 Section: utils
 Description: Captures stdin in a temporary file and runs a command.
 
+Package: with-umask
+Architecture: all
+Section: utils
+Description: Runs a command with a given umask.
+
 Package: create
 Architecture: all
 Section: utils
@@ -127,16 +160,19 @@ Description: Update files in place safely.
 
 Package: stamp
 Architecture: any
+Depends: ${shlibs:Depends}
 Section: utils
 Description: Like cat, but prefixing each line with a datestamp.
 
 Package: getpass
 Architecture: any
+Depends: ${shlibs:Depends}
 Section: utils
 Description: Read a password without echoing; write it to stdout.
 
 Package: space
 Architecture: any
+Depends: ${shlibs:Depends}
 Section: utils
 Description: Identify and fix problematic whitespace in text files.
  The space program won't send you to the moon, but it will identify
@@ -144,8 +180,37 @@ Description: Identify and fix problematic whitespace in text files.
  It can safely update files in place, and could therefore be used as part
  of a commit hook.
 
+Package: sema
+Architecture: any
+Depends: ${shlibs:Depends}
+Section: utils
+Description: Perform simple operations on SysV semaphores.
+ The sema program performs simple operations on (System V-style) semaphores.
+ It's not intended to be a utility for general-purpose hacking on existing
+ semaphores, but rather a tool for doing synchronization between shell
+ scripts or other simple programs.
+
 Package: x86-model
-Architecture: i386
+Architecture: any-i386 any-amd64
+Depends: ${shlibs:Depends}
 Section: utils
 Description: Shows basic model information about x86 processors.
  The cpuid program is probably better for most people.
+
+Package: hush
+Architecture: all
+Section: utils
+Description: Run a command, hiding its output in a logfile unless it fails
+ The hush program is useful for running noisy programs from cron or similar,
+ where you get spammed with uninteresting success reports.  hush runs a
+ command, logging its output, but, unless the command actually fails, it
+ produces no output of its own.
+
+Package: sshsvc-mkauthkeys
+Architecture: all
+Section: utils
+Description: Construct .ssh/authorized_keys files for SSH services.
+ SSH is a fine way to provide services to external users.  It conveniently
+ takes care of details like authenticating users and encrypting
+ communications.  Unfortunately, managing the key files is rather painful.
+ This simple script does a lot of the heavy lifting.