debian/control: Fix missing shlibs dependencies.
[misc] / debian / control
index 7914f51..9af2b32 100644 (file)
@@ -2,16 +2,34 @@ Source: nsict-utils
 Section: utils
 Priority: extra
 Maintainer: Mark Wooding <mdw@distorted.org.uk>
-Build-Depends: tinycdb, bash-builtins, debhelper (>= 4.0.2), python,
- catacomb-dev (>= 2.0.0), mlib-dev (>= 2.0.0), libspamc-dev
+Build-Depends: tinycdb, cdbs, python, python-cdb,
+ catacomb-dev (>= 2.1.1), mlib-dev (>= 2.0.4), libspamc-dev, libcdb-dev
 Standards-Version: 3.1.1
 
 Package: nsict-utils
 Architecture: all
 Section: utils
-Depends: mdwopt-perl, nsict-cdb, locking, qmail-checkspam, nsict-mail,
- if-mtu, shadowfix, zz, gorp, splitconf, xtitle, pause, buf, create, inplace,
- stamp, space
+Depends:
+       mdwopt-perl,
+       nsict-cdb,
+       locking,
+       qmail-checkspam,
+       nsict-mail,
+       if-mtu,
+       shadowfix,
+       zz,
+       gorp,
+       mtimeout,
+       splitconf,
+       xtitle,
+       pause,
+       buf,
+       create,
+       inplace,
+       stamp,
+       space,
+       getpass,
+       hush
 Description: Dummy package for convenience.
 
 Package: mdwopt-perl
@@ -23,9 +41,21 @@ Description: Options parser library for perl.
 Package: nsict-cdb
 Architecture: any
 Section: utils
-Depends: ${shlibs:Depends}, ${python:Depends}, python-cdb
+Depends: ${shlibs:Depends}, python (>= 2.4), python-cdb
 Description: Simple utilities for messing with CDB files.
 
+Package: mtimeout
+Architecture: any
+Section: utils
+Depends: ${shlibs:Depends}
+Description: Run a program for at most a given amount of time.
+
+Package: prlimit
+Architecture: linux-any
+Section: utils
+Depends: ${shlibs:Depends}
+Description: Run a program for at most a given amount of time.
+
 Package: locking
 Architecture: any
 Section: utils
@@ -64,10 +94,10 @@ Description: Run a program, automatically decompressing its argument files.
 
 Package: xtitle
 Architecture: any
-Depends: ${shlibs:Depends}, bash (>= 2.0.0)
+Depends: ${shlibs:Depends}
 Recommends: x-terminal-emulator
 Section: utils
-Description: Bash builtin for messing with xterm title bars.
+Description: Simple program for messing with xterm (or compatible) title bars.
 
 Package: splitconf
 Architecture: all
@@ -104,14 +134,38 @@ Description: Update files in place safely.
 
 Package: stamp
 Architecture: any
+Depends: ${shlibs:Depends}
 Section: utils
 Description: Like cat, but prefixing each line with a datestamp.
 
+Package: getpass
+Architecture: any
+Depends: ${shlibs:Depends}
+Section: utils
+Description: Read a password without echoing; write it to stdout.
+
 Package: space
 Architecture: any
+Depends: ${shlibs:Depends}
 Section: utils
 Description: Identify and fix problematic whitespace in text files.
  The space program won't send you to the moon, but it will identify
  and fix problems such as trailing whitespace and spaces before tabs.
  It can safely update files in place, and could therefore be used as part
  of a commit hook.
+
+Package: x86-model
+Architecture: any-i386 any-amd64
+Depends: ${shlibs:Depends}
+Section: utils
+Description: Shows basic model information about x86 processors.
+ The cpuid program is probably better for most people.
+
+Package: hush
+Architecture: all
+Section: utils
+Description: Run a command, hiding its output in a logfile unless it fails
+ The hush program is useful for running noisy programs from cron or similar,
+ where you get spammed with uninteresting success reports.  hush runs a
+ command, logging its output, but, unless the command actually fails, it
+ produces no output of its own.