prlimit: New program for fiddling with resource limits.
[misc] / debian / control
index 7914f51..15f23a9 100644 (file)
@@ -2,16 +2,33 @@ Source: nsict-utils
 Section: utils
 Priority: extra
 Maintainer: Mark Wooding <mdw@distorted.org.uk>
-Build-Depends: tinycdb, bash-builtins, debhelper (>= 4.0.2), python,
- catacomb-dev (>= 2.0.0), mlib-dev (>= 2.0.0), libspamc-dev
+Build-Depends: tinycdb, cdbs, python, python-cdb,
+ catacomb-dev (>= 2.1.1), mlib-dev (>= 2.0.4), libspamc-dev, libcdb-dev
 Standards-Version: 3.1.1
 
 Package: nsict-utils
 Architecture: all
 Section: utils
-Depends: mdwopt-perl, nsict-cdb, locking, qmail-checkspam, nsict-mail,
- if-mtu, shadowfix, zz, gorp, splitconf, xtitle, pause, buf, create, inplace,
- stamp, space
+Depends:
+       mdwopt-perl,
+       nsict-cdb,
+       locking,
+       qmail-checkspam,
+       nsict-mail,
+       if-mtu,
+       shadowfix,
+       zz,
+       gorp,
+       mtimeout,
+       splitconf,
+       xtitle,
+       pause,
+       buf,
+       create,
+       inplace,
+       stamp,
+       space,
+       getpass
 Description: Dummy package for convenience.
 
 Package: mdwopt-perl
@@ -23,9 +40,21 @@ Description: Options parser library for perl.
 Package: nsict-cdb
 Architecture: any
 Section: utils
-Depends: ${shlibs:Depends}, ${python:Depends}, python-cdb
+Depends: ${shlibs:Depends}, python (>= 2.4), python-cdb
 Description: Simple utilities for messing with CDB files.
 
+Package: mtimeout
+Architecture: any
+Section: utils
+Depends: ${shlibs:Depends}
+Description: Run a program for at most a given amount of time.
+
+Package: prlimit
+Architecture: linux-any
+Section: utils
+Depends: ${shlibs:Depends}
+Description: Run a program for at most a given amount of time.
+
 Package: locking
 Architecture: any
 Section: utils
@@ -64,10 +93,10 @@ Description: Run a program, automatically decompressing its argument files.
 
 Package: xtitle
 Architecture: any
-Depends: ${shlibs:Depends}, bash (>= 2.0.0)
+Depends: ${shlibs:Depends}
 Recommends: x-terminal-emulator
 Section: utils
-Description: Bash builtin for messing with xterm title bars.
+Description: Simple program for messing with xterm (or compatible) title bars.
 
 Package: splitconf
 Architecture: all
@@ -107,6 +136,11 @@ Architecture: any
 Section: utils
 Description: Like cat, but prefixing each line with a datestamp.
 
+Package: getpass
+Architecture: any
+Section: utils
+Description: Read a password without echoing; write it to stdout.
+
 Package: space
 Architecture: any
 Section: utils
@@ -115,3 +149,9 @@ Description: Identify and fix problematic whitespace in text files.
  and fix problems such as trailing whitespace and spaces before tabs.
  It can safely update files in place, and could therefore be used as part
  of a commit hook.
+
+Package: x86-model
+Architecture: any-i386, any-amd64
+Section: utils
+Description: Shows basic model information about x86 processors.
+ The cpuid program is probably better for most people.