Makefile, debian/{control,inst}: Sort the various lists of things.
[misc] / debian / control
index 7914f51..d9d9a22 100644 (file)
@@ -1,49 +1,86 @@
-Source: nsict-utils
+Source: distorted-utils
 Section: utils
 Priority: extra
 Maintainer: Mark Wooding <mdw@distorted.org.uk>
-Build-Depends: tinycdb, bash-builtins, debhelper (>= 4.0.2), python,
- catacomb-dev (>= 2.0.0), mlib-dev (>= 2.0.0), libspamc-dev
+Build-Depends: debhelper (>= 9), pkg-config,
+ libcdb-dev, mlib-dev (>= 2.0.4), catacomb-dev (>= 2.1.1),
+ python, python-cdb,
+ tclsh
 Standards-Version: 3.1.1
 
-Package: nsict-utils
+Package: distorted-utils
 Architecture: all
 Section: utils
-Depends: mdwopt-perl, nsict-cdb, locking, qmail-checkspam, nsict-mail,
- if-mtu, shadowfix, zz, gorp, splitconf, xtitle, pause, buf, create, inplace,
- stamp, space
+Replaces: nsict-utils (<< 1.4.0~)
+Breaks: nsict-utils (<< 1.4.0~)
+Depends:
+       buf,
+       create,
+       distorted-cdb,
+       distorted-mail,
+       getpass,
+       gorp,
+       hush,
+       if-mtu,
+       inplace,
+       locking,
+       mdwopt-perl,
+       mtimeout,
+       pause,
+       shadowfix,
+       space,
+       splitconf,
+       sshsvc-mkauthkeys,
+       stamp,
+       with-umask,
+       xtitle,
+       zz
 Description: Dummy package for convenience.
 
-Package: mdwopt-perl
+Package: buf
 Architecture: all
-Section: perl
-Depends: perl5
-Description: Options parser library for perl.
+Section: utils
+Description: Captures stdin in a temporary file and runs a command.
 
-Package: nsict-cdb
+Package: create
+Architecture: all
+Section: utils
+Description: Simple script encapsulating atomic file update.
+
+Package: distorted-cdb
 Architecture: any
 Section: utils
-Depends: ${shlibs:Depends}, ${python:Depends}, python-cdb
+Replaces: nsict-cdb (<< 1.4.0~)
+Breaks: nsict-cdb (<< 1.4.0~)
+Depends: ${shlibs:Depends}, python (>= 2.4), python-cdb
 Description: Simple utilities for messing with CDB files.
 
-Package: locking
+Package: distorted-mail
+Architecture: all
+Section: mail
+Depends: ${shlibs:Depends}, qmail, distorted-cdb, perl5, libmime-perl
+Description: Some simple scripts for mail handling.
+
+Package: getpass
 Architecture: any
-Section: utils
 Depends: ${shlibs:Depends}
-Description: Run a program while holding a file lock.
+Section: utils
+Description: Read a password without echoing; write it to stdout.
 
-Package: qmail-checkspam
+Package: gorp
 Architecture: any
-Section: mail
-Depends: ${shlibs:Depends}, qmail
-Suggests: spamassassin
-Description: Check mail for spamminess before queueing it.
+Depends: ${shlibs:Depends}
+Section: utils
+Description: Print a random base64 string.
 
-Package: nsict-mail
+Package: hush
 Architecture: all
-Section: mail
-Depends: qmail, nsict-cdb, perl5, libmime-perl
-Description: Some simple scripts for mail handling.
+Section: utils
+Description: Run a command, hiding its output in a logfile unless it fails
+ The hush program is useful for running noisy programs from cron or similar,
+ where you get spammed with uninteresting success reports.  hush runs a
+ command, logging its output, but, unless the command actually fails, it
+ produces no output of its own.
 
 Package: if-mtu
 Architecture: any
@@ -51,35 +88,28 @@ Section: utils
 Depends: ${shlibs:Depends}
 Description: Report the MTU of a network interface.
 
-Package: shadowfix
-Architecture: all
-Section: utils
-Depends: perl5, mdwopt-perl
-Description: Check and fix shadow password and group files.
-
-Package: zz
+Package: inplace
 Architecture: all
 Section: utils
-Description: Run a program, automatically decompressing its argument files.
+Description: Update files in place safely.
 
-Package: xtitle
+Package: locking
 Architecture: any
-Depends: ${shlibs:Depends}, bash (>= 2.0.0)
-Recommends: x-terminal-emulator
 Section: utils
-Description: Bash builtin for messing with xterm title bars.
+Depends: ${shlibs:Depends}
+Description: Run a program while holding a file lock.
 
-Package: splitconf
+Package: mdwopt-perl
 Architecture: all
-Depends: tclsh
-Section: utils
-Description: Gather little config files into one big one.
+Section: perl
+Depends: perl5
+Description: Options parser library for perl.
 
-Package: gorp
+Package: mtimeout
 Architecture: any
-Depends: ${shlibs:Depends}
 Section: utils
-Description: Print a random base64 string.
+Depends: ${shlibs:Depends}
+Description: Run a program for at most a given amount of time.
 
 Package: pause
 Architecture: any
@@ -87,31 +117,100 @@ Depends: ${shlibs:Depends}
 Section: utils
 Description: Wait for a given time, or until a key is pressed.
 
-Package: buf
+Package: prlimit
+Architecture: linux-any
+Section: utils
+Depends: ${shlibs:Depends}
+Description: Run a program for at most a given amount of time.
+
+Package: sema
+Architecture: any
+Depends: ${shlibs:Depends}
+Section: utils
+Description: Perform simple operations on SysV semaphores.
+ The sema program performs simple operations on (System V-style) semaphores.
+ It's not intended to be a utility for general-purpose hacking on existing
+ semaphores, but rather a tool for doing synchronization between shell
+ scripts or other simple programs.
+
+Package: shadowfix
 Architecture: all
 Section: utils
-Description: Captures stdin in a temporary file and runs a command.
+Depends: perl5, mdwopt-perl
+Description: Check and fix shadow password and group files.
 
-Package: create
+Package: space
+Architecture: any
+Depends: ${shlibs:Depends}
+Section: utils
+Description: Identify and fix problematic whitespace in text files.
+ The space program won't send you to the moon, but it will identify
+ and fix problems such as trailing whitespace and spaces before tabs.
+ It can safely update files in place, and could therefore be used as part
+ of a commit hook.
+
+Package: splitconf
 Architecture: all
+Depends: tclsh
 Section: utils
-Description: Simple script encapsulating atomic file update.
+Description: Gather little config files into one big one.
 
-Package: inplace
+Package: sshsvc-mkauthkeys
 Architecture: all
 Section: utils
-Description: Update files in place safely.
+Description: Construct .ssh/authorized_keys files for SSH services.
+ SSH is a fine way to provide services to external users.  It conveniently
+ takes care of details like authenticating users and encrypting
+ communications.  Unfortunately, managing the key files is rather painful.
+ This simple script does a lot of the heavy lifting.
 
 Package: stamp
 Architecture: any
+Depends: ${shlibs:Depends}
 Section: utils
 Description: Like cat, but prefixing each line with a datestamp.
 
-Package: space
+Package: with-umask
+Architecture: all
+Section: utils
+Description: Runs a command with a given umask.
+
+Package: x86-model
+Architecture: any-i386 any-amd64
+Depends: ${shlibs:Depends}
+Section: utils
+Description: Shows basic model information about x86 processors.
+ The cpuid program is probably better for most people.
+
+Package: xtitle
 Architecture: any
+Depends: ${shlibs:Depends}
+Recommends: x-terminal-emulator
 Section: utils
-Description: Identify and fix problematic whitespace in text files.
- The space program won't send you to the moon, but it will identify
- and fix problems such as trailing whitespace and spaces before tabs.
- It can safely update files in place, and could therefore be used as part
- of a commit hook.
+Description: Simple program for messing with xterm (or compatible) title bars.
+
+Package: zz
+Architecture: all
+Section: utils
+Description: Run a program, automatically decompressing its argument files.
+
+Package: nsict-cdb
+Architecture: all
+Section: oldlibs
+Depends: distorted-cdb
+Description: Dummy package for transition.
+ This is a transitional dummy package.  It can safely be removed.
+
+Package: nsict-mail
+Architecture: all
+Section: oldlibs
+Depends: distorted-mail
+Description: Dummy package for transition.
+ This is a transitional dummy package.  It can safely be removed.
+
+Package: nsict-utils
+Architecture: all
+Section: oldlibs
+Depends: distorted-utils
+Description: Dummy package for transition.
+ This is a transitional dummy package.  It can safely be removed.