sshsvc-mkauthkeys: A new script joins the collection.
[misc] / debian / control
index 612e813..fa05cca 100644 (file)
@@ -28,7 +28,9 @@ Depends:
        stamp,
        space,
        getpass,
-       hush
+       hush,
+       with-umask,
+       sshsvc-mkauthkeys
 Description: Dummy package for convenience.
 
 Package: mdwopt-perl
@@ -114,6 +116,11 @@ Architecture: all
 Section: utils
 Description: Captures stdin in a temporary file and runs a command.
 
+Package: with-umask
+Architecture: all
+Section: utils
+Description: Runs a command with a given umask.
+
 Package: create
 Architecture: all
 Section: utils
@@ -161,3 +168,12 @@ Description: Run a command, hiding its output in a logfile unless it fails
  where you get spammed with uninteresting success reports.  hush runs a
  command, logging its output, but, unless the command actually fails, it
  produces no output of its own.
+
+Package: sshsvc-mkauthkeys
+Architecture: all
+Section: utils
+Description: Construct .ssh/authorized_keys files for SSH services.
+ SSH is a fine way to provide services to external users.  It conveniently
+ takes care of details like authenticating users and encrypting
+ communications.  Unfortunately, managing the key files is rather painful.
+ This simple script does a lot of the heavy lifting.