debian/: Bump to Debhelper 10.
[mLib] / debian / rules
index bbbc852..4bd7c2c 100755 (executable)
@@ -31,7 +31,7 @@ DH_BUILD_OVERRIDES = configure clean build install test
 ## How to perform build action for a particular library flavour.
 define flavour-build-action
 dh_auto_$1 -Bdebian/build-$2 \
-       $(DH_OPTIONS) $(DH_OPTIONS_$2) \
+       $(addprefix -O, $(DH_OPTIONS)) $(DH_OPTIONS_$2) \
        $(DH_$1_OPTIONS) $(DH_$1_OPTIONS_$2)
 
 endef
@@ -58,6 +58,9 @@ DH_install_OPTIONS_adns = --destdir=debian/tmp-adns
 ###--------------------------------------------------------------------------
 ### Additional tweaks.
 
+## Don't try to rebuild our configure script.
+DH_OPTIONS += --without=autoreconf
+
 ## Some of the install lists need to be generated.  This is a little
 ## annoying.
 GEN_INSTALL_PKGS = mlib2-adns