debian/: Ship correct symbols files.
[mLib] / debian / rules
index 8635ec0..bbbc852 100755 (executable)
@@ -14,10 +14,10 @@ DEB_UPSTREAM_VERSION ?= \
 v := $(DEB_UPSTREAM_VERSION)
 
 ## Default Debhelper options.
-DH_OPTIONS =
+DH_OPTIONS = --parallel
 
 ## Default Debhelper actions.
-%:; dh $@ --without autoreconf $(DH_OPTIONS)
+%:; dh $@ $(DH_OPTIONS)
 
 ###--------------------------------------------------------------------------
 ### Multiple flavours.
@@ -69,8 +69,8 @@ dh-install-hook:: $(GEN_INSTALL_FILES); @:
 dh-clean-hook::
        rm -f $(GEN_INSTALL_FILES)
 
-## Override the shared-library dependency information to allow any flavour.
+## Check that the shared-library symbols are plausible.
 override_dh_makeshlibs:
-       dh_makeshlibs -V"mlib2 (>= $v) | mlib2-adns (>= $v)"
+       dh_makeshlibs -- -c4
 
 ###----- That's all, folks --------------------------------------------------