packaging fixes - really now it installs on xenophobe
[hippotat] / debian / rules
index 17bbf5e..375d057 100755 (executable)
@@ -7,9 +7,14 @@ export PYBUILD_INSTALL_DIR=/usr/share/hippotat/python3
 %:
        dh $@ --with python3 --buildsystem=pybuild
 
+i=debian/hippotat
+
 debian/copyright: COPYING AGPLv3+CAFv2
        cat $^ >$@.tmp && mv -f $@.tmp $@
 
+override_dh_installinit:
+       dh_installinit --name=hippotatd
+
 override_dh_compress:
-       find debian/hippotat/usr/{bin,sbin} -type f | xargs ./subst-sys-path
+       find $i/usr/{bin,sbin} -type f | xargs ./subst-sys-path
        dh_compress