packaging fixes - really now it installs on xenophobe
[hippotat] / debian / hippotat.postinst
index b406e55..7954152 100644 (file)
@@ -1,6 +1,13 @@
 #!/bin/sh
 set -e
-mkdir -p -m700 /etc/hippotat
+
 adduser --system --group --force-badname --shell=/bin/bash \
-       --home /etc/hippotat Debian-hippotat
+       --quiet --home /etc/hippotat Debian-hippotat
+
+umask 077
+
+pd=/etc/hippotat/passwords.d
+test -d $pd || \
+install -m 750 -o root -g Debian-hippotat -d $pd
+
 #DEBHELPER#