config: sort out directory handling
[hippotat] / debian / hippotat.postinst
index b406e55..5cf0faf 100644 (file)
@@ -1,6 +1,13 @@
 #!/bin/sh
 set -e
-mkdir -p -m700 /etc/hippotat
+
 adduser --system --group --force-badname --shell=/bin/bash \
        --home /etc/hippotat Debian-hippotat
+
+umask 077
+
+pd=/etc/hippotat/passwords.d
+test -d $pd || \
+install -m750 -o root -g Debian-hippotat $pd
+
 #DEBHELPER#