Move images.h to images/ directory, and limit to just the images that
[disorder] / debian / rules
index a4dfdc4..f761888 100755 (executable)
@@ -60,12 +60,14 @@ SENDMAIL=/usr/sbin/sendmail
 LIBTOOL=./libtool
 FAKEROOT=fakeroot
 
-# ./prepare is the script that generates configure etc.  It only needs to be
+SHELL=bash
+
+# ./autogen.sh is the script that generates configure etc.  It only needs to be
 # run if building from a checkout rather than a tarball.
 build:
        @set -e;if test ! -f configure; then \
-         echo ./prepare;\
-         ./prepare;\
+         echo ./autogen.sh;\
+         ./autogen.sh;\
        fi
        @set -e;if test ! -f config.status; then \
          echo ./configure ${CONFIGURE} ${CONFIGURE_EXTRA};\
@@ -141,6 +143,9 @@ pkg-disorder-server: build
        $(MKDIR) debian/disorder-server
        $(MKDIR) debian/disorder-server/DEBIAN
        $(MKDIR) debian/disorder-server/usr/share/doc/disorder-server
+       $(MKDIR) debian/disorder-server/usr/share/lintian/overrides
+       $(INSTALL_DATA) debian/overrides.disorder-server \
+           debian/disorder-server/usr/share/lintian/overrides/disorder-server
        $(INSTALL_DATA) debian/copyright \
                debian/disorder-server/usr/share/doc/disorder-server/copyright
        $(INSTALL_DATA) debian/changelog \