Suppress bogus doc-base registration warnings from lintian.
[disorder] / debian / rules
index 481b2ae..cf66044 100755 (executable)
@@ -20,17 +20,15 @@ cgiexecdir=/usr/lib/cgi-bin
 httpdir=/var/www
 browser=x-www-browser
 
+CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
+CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
+CXXFLAGS:=$(shell dpkg-buildflags --get CXXFLAGS)
+LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
+export CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+
 # Options to configure.  This can be overridden by the caller if necessary.
 CONFIGURE=--prefix=/usr --sysconfdir=/etc --localstatedir=/var/lib --mandir=/usr/share/man --with-browser=${browser} cgiexecdir="${cgiexecdir}" httpdir="${httpdir}"
 
-# Set DEB_BUILD_OPTIONS=noopt to produce a non-optimized build.
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-CFLAGS=-O0 -g
-else
-CFLAGS=-O2 -g
-endif
-export CFLAGS
-
 # Install commands.  You wouldn't normally override these.
 INSTALL=install
 INSTALL_DATA=$(INSTALL) -p -o root -g root -m 644
@@ -69,13 +67,7 @@ build:
          echo ./autogen.sh;\
          ./autogen.sh;\
        fi
-       @set -e;if test ! -f config.status; then \
-         echo ./configure ${CONFIGURE} ${CONFIGURE_EXTRA};\
-         ./configure ${CONFIGURE} ${CONFIGURE_EXTRA};\
-       else\
-         echo ./config.status;\
-         ./config.status;\
-       fi
+       ./configure ${CONFIGURE} ${CONFIGURE_EXTRA}
        $(MAKE) SENDMAIL=${SENDMAIL} ${PARALLEL}
 
 pkg-disorder: build
@@ -83,6 +75,7 @@ pkg-disorder: build
        $(MKDIR) debian/disorder
        $(MKDIR) debian/disorder/DEBIAN
        $(MKDIR) debian/disorder/usr/share/doc/disorder
+       $(MKDIR) debian/disorder/usr/share/lintian/overrides
        $(MKDIR) debian/disorder/etc/bash_completion.d
        $(INSTALL_DATA) debian/copyright \
                debian/disorder/usr/share/doc/disorder/copyright
@@ -101,6 +94,8 @@ pkg-disorder: build
            $(INSTALL_SCRIPT) debian/$$f.disorder debian/disorder/DEBIAN/$$f; \
          fi;\
        done
+       $(INSTALL_DATA) debian/overrides.disorder \
+               debian/disorder/usr/share/lintian/overrides/disorder
        $(MAKE) DESTDIR=`pwd`/debian/disorder installdirs install -C doc
        $(MAKE) DESTDIR=`pwd`/debian/disorder installdirs install -C clients
        strip --remove-section=.comment debian/disorder/usr/bin/disorder
@@ -223,6 +218,7 @@ pkg-disorder-playrtp: build
        $(MKDIR) debian/disorder-playrtp
        $(MKDIR) debian/disorder-playrtp/DEBIAN
        $(MKDIR) debian/disorder-playrtp/usr/share/doc/disorder-playrtp
+       $(MKDIR) debian/disorder-playrtp/usr/share/lintian/overrides
        $(INSTALL_DATA) debian/copyright \
                debian/disorder-playrtp/usr/share/doc/disorder-playrtp/copyright
        $(INSTALL_DATA) debian/changelog \
@@ -234,6 +230,8 @@ pkg-disorder-playrtp: build
            $(INSTALL_SCRIPT) debian/$$f.disorder-playrtp debian/disorder-playrtp/DEBIAN/$$f; \
          fi;\
        done
+       $(INSTALL_DATA) debian/overrides.disorder-playrtp \
+               debian/disorder-playrtp/usr/share/lintian/overrides/disorder-playrtp
        $(MKDIR) debian/disorder-playrtp/usr/bin
        $(MKDIR) debian/disorder-playrtp/usr/share/man/man1
        $(INSTALL_PROGRAM) clients/disorder-playrtp \