Automate installation of the CGI at last.
[disorder] / debian / rules
index e030330..831fd68 100755 (executable)
@@ -155,7 +155,7 @@ pkg-disorder-server: build
                debian/disorder-server/etc/disorder/options
        $(INSTALL_DATA) debian/etc.disorder.options.user \
                debian/disorder-server/etc/disorder/options.user
-       $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) cgi/disorder.cgi \
+       $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) cgi/disorder \
                $(shell pwd)/debian/disorder-server/usr/lib/cgi-bin/disorder
        dpkg-shlibdeps -Tdebian/substvars.disorder-server \
                debian/disorder-server/usr/lib/cgi-bin/disorder \
@@ -194,9 +194,8 @@ pkg-disorder-playrtp: build
                debian/disorder-playrtp/usr/bin/*
        $(INSTALL_DATA) debian/README.RTP \
                debian/disorder-playrtp/usr/share/doc/disorder-playrtp/README
-       $(INSTALL_DATA) CHANGES debian/disorder-playrtp/usr/share/doc/disorder-playrtp/CHANGES
-       gzip -9f debian/disorder-playrtp/usr/share/doc/disorder-playrtp/CHANGES \
-                debian/disorder-playrtp/usr/share/man/man*/*
+       $(INSTALL_DATA) CHANGES.html debian/disorder-playrtp/usr/share/doc/disorder-playrtp/CHANGES.html
+       gzip -9f debian/disorder-playrtp/usr/share/man/man*/*
        dpkg-gencontrol -isp -pdisorder-playrtp -Pdebian/disorder-playrtp -Tdebian/substvars.disorder-playrtp
        chown -R root:root debian/disorder-playrtp
        chmod -R g-ws debian/disorder-playrtp