aclocal: When checking for `environ', don't find `__environ'.
[cfd] / debian / rules
index 99b8a03..47eb20d 100755 (executable)
@@ -1,5 +1,7 @@
 #! /usr/bin/make -f
 
+export DH_COMPAT = 4
+
 build:
        rm -rf build deb-build
        mkdir deb-build
@@ -7,9 +9,13 @@ build:
        make -C deb-build
        touch build
 
+clean:
+       dh_clean
+       rm -rf deb-build build
+
 install: build
        dh_clean
-       make -C deb-build install DESTDIR=`pwd`/debian/tmp
+       make -C deb-build install DESTDIR=`pwd`/debian/cfd
 
 binary-indep: install
        dh_testdir -i
@@ -29,7 +35,7 @@ binary: binary-indep binary-arch
 
 source:
        rm -rf deb-build/*.tar.gz deb-build/=deb=
-       make -C deb-build dist
+       make -C deb-build dist PACKAGE=cfd
        mkdir deb-build/=deb=
        cd deb-build/=deb=; tar xvfz ../*.tar.gz
        d=`pwd`; cd ..; dpkg-source -i -b $$d/deb-build/=deb=/*