symm/des.c: Introduce a function to fix or check key parity.
[catacomb] / debian / control
index 056012d..039f3dc 100644 (file)
@@ -1,17 +1,81 @@
-Source: cfd
-Section: devel
+Source: catacomb
+Section: libs
 Priority: extra
-Maintainer: Mark Wooding <mdw@nsict.org>
-Build-Depends: debhelper (>> 8.0)
+Build-Depends: debhelper (>= 10), autoconf-archive, python,
+ valgrind [!armel], pkg-config, mlib-dev (>= 2.4.1)
+Maintainer: Mark Wooding <mdw@distorted.org.uk>
 Standards-Version: 3.1.1
 
-Package: cfd
-Architecture: all
-Recommends: autoconf, automake
-Description: A collection of miscellaneous bits of build system.
- The common files distribution (CFD) contains standard boilerplate files
- and some handy autoconf macros.  It also contains some scripts which
- add symlinks to the master copies of these files to a directory, the
- idea being that you don't need to check these files into your CVS
- repository for every project.  Instead, include a script which sets
- up the symlinks correctly.
+Package: catacomb2
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}
+Pre-Depends: ${misc:Pre-Depends}
+Recommends: catacomb-bin, catacomb-data
+Breaks: python-catacomb (<< 1.1.2)
+Description: A cryptographic library
+ Catacomb is a cryptographic library.  It implements a large number of
+ encryption algorithms, hash functions, message authentication codes
+ and random number generators.  It has a multi-precision maths library,
+ for implementing public key schemes such as RSA, DSA and Diffie-Hellman.
+ It contains rudimentary key-management tools.
+ .
+ The objective of Catacomb is to make a crypto library which is
+ relatively straightforward to audit for security.  Its focus is on
+ clarity of source code and portability more than performance.
+ .
+ This package just contains the shared library.  If you want to develop
+ programs which use the library, you need catacomb-dev.
+
+Package: catacomb-bin
+Architecture: any
+Depends: ${shlibs:Depends}, catacomb2 (= ${binary:Version}), ${misc:Depends}
+Suggests: utils
+Description: A cryptographic library
+ Catacomb is a cryptographic library.  It implements a large number of
+ encryption algorithms, hash functions, message authentication codes
+ and random number generators.  It has a multi-precision maths library,
+ for implementing public key schemes such as RSA, DSA and Diffie-Hellman.
+ It contains rudimentary key-management tools.
+ .
+ The objective of Catacomb is to make a crypto library which is
+ relatively straightforward to audit for security.  Its focus is on
+ clarity of source code and portability more than performance.
+ .
+ This package contains a tool for key management, a passphrase
+ pixie, and other stuff.
+
+Package: catacomb-data
+Architecture: any
+Description: A cryptographic library
+ Catacomb is a cryptographic library.  It implements a large number of
+ encryption algorithms, hash functions, message authentication codes
+ and random number generators.  It has a multi-precision maths library,
+ for implementing public key schemes such as RSA, DSA and Diffie-Hellman.
+ It contains rudimentary key-management tools.
+ .
+ The objective of Catacomb is to make a crypto library which is
+ relatively straightforward to audit for security.  Its focus is on
+ clarity of source code and portability more than performance.
+ .
+ This package contains some documentation files which users of the library
+ may find useful.
+
+Package: catacomb-dev
+Architecture: any
+Depends: catacomb2 (= ${binary:Version}), mlib-dev (>= 2.2.2.1)
+Recommends: catacomb-bin
+Section: devel
+Description: A cryptographic library
+ Catacomb is a cryptographic library.  It implements a large number of
+ encryption algorithms, hash functions, message authentication codes
+ and random number generators.  It has a multi-precision maths library,
+ for implementing public key schemes such as RSA, DSA and Diffie-Hellman.
+ It contains rudimentary key-management tools.
+ .
+ The objective of Catacomb is to make a crypto library which is
+ relatively straightforward to audit for security.  Its focus is on
+ clarity of source code and portability more than performance.
+ .
+ This package contains the headers and static libraries needed for
+ building programs which use the library.