debian/changelog: Prepare for next minor version.
[catacomb] / debian / changelog
index 066dcc5..19115e9 100644 (file)
@@ -1,3 +1,57 @@
+catacomb (2.6.99~) experimental; urgency=medium
+
+  * (placeholder for next minor version)
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sat, 29 Aug 2020 00:42:11 +0100
+
+catacomb (2.6.2) experimental; urgency=medium
+
+  * catacomb: Fix incorrect feature test for AESNI on Intel processors.
+    (This was introduced in 2.6.0.  Workaround for affected processors on
+    2.6.0 and 2.6.1: set `CATACOMB_CPUFEAT' to `-x86:aesni'.)
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sat, 13 Jun 2020 18:10:53 +0100
+
+catacomb (2.6.1) experimental; urgency=medium
+
+  * catacomb: Fix segfault from `rand_quick' on i386.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Mon, 25 May 2020 17:45:02 +0100
+
+catacomb (2.6.0) experimental; urgency=medium
+
+  * catacomb: Introduce Mike Hamburg's `STROBE' syymetric encryption
+    framework, based on Keccak.
+  * catacomb: Fix KCDSA prime generation so that it makes primes of
+    exactly the right length.  I think this is the last of the prime-
+    generation algorthms that needs fixing.
+  * catacomb: Inttroduce low-level key-file functions to accommodate
+    Python 3 bindings.
+  * catacomb: Support `tag:', `id:' and `type:' prefixes in `bytag' key
+    queries.
+  * catacomb-bin: Be consistent about metasyntax used to denote hash
+    function names.
+  * catacomb: Introduce fast SIMD multiplication for ARM32 and ARM64
+    platforms.  I think this finally means that X86 and ARM have similar
+    levels of optimization.
+  * catacomb: Check SIMD feature bit on ARM64 before using the optimized
+    code.  I don't know of any ARM64 implementations which lack SIMD
+    instructions, but the bit must be there for a reason, so I might as
+    well use it.
+  * catacomb-dev: Allow reading the current number of passes from a
+    `dsarand' object.
+  * catacomb: Prefer X84 `rdseed' instruction for quick entropy over
+    `rdrand' if it's available.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sat, 09 May 2020 17:38:45 +0100
+
+catacomb (2.5.2) experimental; urgency=medium
+
+  * Merge changes from 2.4.5.
+  * catacomb-dev: Fix ARM32 FP/SIMD register dumping.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sat, 09 May 2020 20:50:57 +0100
+
 catacomb (2.5.1) experimental; urgency=medium
 
   * Merge changes from 2.4.4.
@@ -23,6 +77,45 @@ catacomb (2.5.0) experimental; urgency=medium
 
  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 21 Sep 2019 21:26:44 +0100
 
+catacomb (2.4.5) experimental; urgency=medium
+
+  * catacomb: Fix memory leak in key-file error handling.
+  * catacomb: Don't leak internal `exptime' symbol into the global
+    namespace.
+  * catacomb: Check that the X86 `rdrand' instruction actually works
+    before leaning on it.  This is in response to the well-publicized AMD
+    bug which always returns all-bits-set with the carry /set/ (indicating
+    success).
+  * catacomb: Mix in the random pool key during `rand_gate' and
+    `rand_stretch' operations.
+  * catacomb: Fix by-tag key lookups: if the query string looks like a hex
+    number, it's treated as a search by id; but if no such id is found,
+    the search wouldn't continue to look for a key by type or tag.
+  * catacomb: Fix reference leak in `key_split'.
+  * catacomb: Fix bug which completely broke `key_copydata'.
+  * catacomb: Fix segfault from `pgen', if it fails before setting up the
+    prime tester.
+  * catacomb: Propagate failure from `pgen' during Lim--Lee prime
+    generation, rather than immediately retrying.
+  * catacomb: Fix memory leak of factor vector from failed Lim--Lee prime
+    generation.
+  * catacomb: Fix segfault when multiplying the identity elliptic-curve
+    point.
+  * catacomb: Fix the `lcrand' descriptor, so that it's not advertised as
+    being cryptographically strong, and to fix a bias in its output.
+  * catacomb: Fix a memory leak in the error case of KCDSA prime
+    generation.
+  * catacomb-bin: Fix segfault from `pixie', if given an empty passphrase
+    to remember.
+  * catacomb: Check SIMD feature bit on ARM64 before using the optimized
+    code.  I don't know of any ARM64 implementations which lack SIMD
+    instructions, but the bit must be there for a reason, so I might as
+    well use it.
+  * catacomb: Support parsing binary-group descriptions.  This is a long-
+    standing lacuna that I've only recently noticed.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sat, 09 May 2020 17:46:24 +0100
+
 catacomb (2.4.4) experimental; urgency=medium
 
   * debian: Bump to Debhelper 10.