prime generation: Deploy the new Baillie--PSW testers.
[catacomb] / debian / rules
index f005c81..9c783b7 100755 (executable)
@@ -1,43 +1,12 @@
 #! /usr/bin/make -f
+DH_OPTIONS = --parallel -Bdebian/build
+%:; dh $@ $(DH_OPTIONS)
 
-build:
-       rm -rf build deb-build
-       mkdir deb-build
-       cd deb-build; ../configure --prefix=/usr --infodir=/usr/share/info
-       make -C deb-build
-       touch build
+## Test both with and without CPU-specific optimizations.
+override_dh_auto_test:
+       dh_auto_test $(addprefix -O, $(DH_OPTIONS))
+       CATACOMB_CPUFEAT="-*" dh_auto_test $(addprefix -O, $(DH_OPTIONS))
 
-clean:
-       dh_clean
-       rm -rf deb-build build
-
-install: build
-       dh_clean
-       make -C deb-build install DESTDIR=`pwd`/debian/tmp
-
-binary-indep: install
-       dh_testdir -i
-       dh_testroot -i
-       dh_installinfo -i common.info
-       dh_compress -i
-       dh_installdocs -i
-       dh_gencontrol -i
-       dh_fixperms -i
-       dh_installdeb -i
-       dh_md5sums -i
-       dh_builddeb -i
-
-binary-arch:
-
-binary: binary-indep binary-arch
-
-source:
-       rm -rf deb-build/*.tar.gz deb-build/=deb=
-       make -C deb-build dist PACKAGE=cfd
-       mkdir deb-build/=deb=
-       cd deb-build/=deb=; tar xvfz ../*.tar.gz
-       d=`pwd`; cd ..; dpkg-source -i -b $$d/deb-build/=deb=/*
-       rm -rf deb-build/=deb=
-
-.PHONY: binary binary-arch binary-indep clean install source 
-EOF
+## Check that the shared-library symbols are plausible.
+override_dh_makeshlibs:
+       dh_makeshlibs -- -c4