base/dispatch.c, etc.: Replace inline assembler for the `rdrand' fix.
[catacomb] / debian / changelog
index 265161f..db77dc1 100644 (file)
@@ -1,3 +1,77 @@
+catacomb (2.5.99~) experimental; urgency=medium
+
+  * (placeholder for next minor release)
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Mon, 30 Sep 2019 02:15:20 +0100
+
+catacomb (2.5.1) experimental; urgency=medium
+
+  * Merge changes from 2.4.4.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sun, 29 Sep 2019 17:50:59 +0100
+
+catacomb (2.5.0) experimental; urgency=medium
+
+  * catacomb: MACs based on blockciphers: PMAC1 and CMAC (also known as
+    OMAC).
+  * catacomb: Authenticated Encryption with Additional Data (AEAD)
+    schemes.  Some based on blockciphers: CCM, EAX, GCM (with CPU-specific
+    acceleration), OCB1 and OCB3 (OCB2 is broken).  Also Salsa20 and
+    ChaCha20 with Poly1305: the RFC7539 scheme, and the NaCl `secret_box'
+    transform.
+  * catacomb: Implement Grantham's Frobenius test.  Combine it with
+    Rabin--Miller, as Baillie--PSW, for testing given primes.
+  * catacomb-bin (catcrypt): Support AEAD schemes for bulk crypto.
+  * catacomb-bin (perftest): Options for batching; report cycle counts
+    where available.
+  * Many internal improvements: better documentation, debugging, testing,
+    etc.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sat, 21 Sep 2019 21:26:44 +0100
+
+catacomb (2.4.4) experimental; urgency=medium
+
+  * debian: Bump to Debhelper 10.
+  * debian: Ship a shared-library `symbols' file for more precise
+    dependencies.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sun, 29 Sep 2019 15:58:26 +0100
+
+catacomb (2.4.3) experimental; urgency=medium
+
+  * catacomb (idea): Fix key-length descriptor.
+  * catacomb (xchachaNN): Fix nonce-size descriptor.
+  * catacomb (key-management): Fix incorrect handling of keyring
+    modifiability.
+  * catacomb-dev: Configure `pkg-config' correctly for static linking.
+  * catacomb, catacomb-bin (cookie, dsig): Fix hash-function length
+    padding on very long messages, and handling of large datestamps.
+  * catacomb-bin (catsign): Don't open temporary files unnecessarily.
+  * catacomb-bin (catcrypt): Fix key-attribute parsing.
+  * catacomb-bin (perftest): Add missing help-string text for `-n' used
+    with `enc' and `hash'
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sat, 21 Sep 2019 17:43:59 +0100
+
+catacomb (2.4.2) experimental; urgency=medium
+
+  * catacomb2: Support multi-arch at last.
+  * catacomb2: Fix mangled key-size data for HMAC.
+  * rspit: Support generating large files.
+  * pixie: Improve error-handling around dropping privilege.
+  * ed25519, ed448: Very minor performance improvement.
+  * salsa20, chacha: Fix crash if nonce is none, as it is when invoked by
+    `rspit'.
+  * salsa20, chacha: Fix declaration of cipher classes to prevent them
+    ending up as (useless) common symbols in client code.
+  * limlee: Improve the prime size heuristics.
+  * sha, sha256, sha512: Restructure compression function to improve
+    performance and use less memory.
+  * rijndael: Include enough round constants to make very tiny keys work
+    correctly.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Tue, 12 Jun 2018 01:15:59 +0100
+
 catacomb (2.4.1) experimental; urgency=low
 
   * catacomb2: Two's-complement fix from 2.3.x release branch.