Release 2.2.4.
[catacomb] / debian / changelog
index 2f12b70..8890ce8 100644 (file)
@@ -1,3 +1,117 @@
+catacomb (2.2.4) experimental; urgency=low
+
+  * build: Fix build failures on post-wheezy Debian versions.
+  * catacomb2: Use ARM AES instructions if available.  (But they can't be
+    assembled using wheezy's version of gas, so this doesn't work in the
+    binary package.)
+  * catacomb2: Fix poor performance (and wrong answers for very small
+    numbers) in prime generation.
+  * catacomb2: Return numbers of exactly the requested length in prime and
+    public-key generation.  The `strongprime' and `limlee' algorithms have
+    changed as a result; previously verifiable parameters generated using
+    this algorithm won't be verifiable any more.
+  * catacomb-dev: Deprecate the old `dsa' functions.  Use `gdsa' instead.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sun, 26 Jun 2016 14:18:14 +0100
+
+catacomb (2.2.3) experimental; urgency=low
+
+  * rand: Make the main generator resiliant in the face of fork(2).
+  * rand: Introduce `rand_quick', which may also mix in CPU-level
+    randomness sources.
+  * rand: Use higher-resolution timer in the quick-win noise source.
+  * debian: Pick up correct `catacomb-dev' Depends entry from 2.2.1.1
+    which got lost down the side of the sofas.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Mon, 13 Jun 2016 22:22:33 +0100
+
+catacomb (2.2.2) experimental; urgency=low
+
+  * build: Cope with newer Autotools and related equipment.
+  * Miscellaneous small fixes for Cygwin.
+  * catacomb2 (mp_testbit): Fix overread on reading one-bit-past-the-end;
+    particularly, this causes a segfault reading bit zero of a zero-length
+    integer.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sat, 04 Jun 2016 01:12:01 +0100
+
+catacomb (2.2.1.1) experimental; urgency=low
+
+  * Arrange that catacomb-dev Depends on correct version of mlib-dev.  It
+    really won't work well without it.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Fri, 19 Feb 2016 09:04:50 +0000
+
+catacomb (2.2.1) experimental; urgency=low
+
+  * Some internal improvements.
+  * Debian packaging cleanups (fix build-depends, update mLib dependency).
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Thu, 18 Feb 2016 16:43:09 +0000
+
+catacomb (2.2.0) experimental; urgency=low
+
+  * catacomb2: Fix rsa_recover crash on even modulus.
+  * catacomb-bin: Report error taking factorial of negative input.
+  * catacomb2: Fix EC_FIND and EC_NEG on 2-torsion points of prime curves.
+  * catacomb-dev: Support multiple flavours of EC point compression.
+  * catacomb2: Fix theoretical rsa_recover crash if factoring loop runs
+    out of prime numbers.
+  * catacomb2: Overhaul crypto primitives used in true-random generator.
+  * catacomb-bin: Improve rspit: high-resolution timing, and 64-bit size
+    support.
+  * catacomb-dev: New conversions between MP integers and C integer types.
+  * catacomb2: Change gcipher for Seal incompatibly.  The IV is now
+    big-endian bytes (rather than `uint32'), and the `block size' is 4.
+  * catacomb2: Mix a constant string into DSA nonce generation to improve
+    resistance to protocol interference.
+  * catacomb2: Fix the freewheel random source, which hasn't been enabled
+    for ages due to a configure-script bug.
+  * catacomb-bin: The key tool can now read and write multiple
+    presentations for key fingerprints.
+  * catacomb2, catacomb-dev: Support Daniel Bernstein's Salsa20 and ChaCha
+    stream ciphers.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Mon, 20 Jul 2015 14:15:31 +0100
+
+catacomb (2.1.7) experimental; urgency=low
+
+  * A number of entropy-source fixes.
+  * Internal tidying.
+  * Add more elliptic curves, from Brainpool and BADA55.
+  * hashsum: Fix hash file verification.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Wed, 16 Jul 2014 10:21:23 +0100
+
+catacomb (2.1.6.1) experimental; urgency=low
+
+  * Fix building from source tarball.
+  * Fix building with Python 2.5.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sat, 28 Dec 2013 14:21:36 +0000
+
+catacomb (2.1.6) experimental; urgency=low
+
+  * mpreduce: Extend domain to all positive integers.
+  * gfreduce: Fix out-of-bounds memory access.
+  * gcd: Don't clobber signs of `constants' when GCD calculation is trivial.
+  * pixie: Don't replace existing pixie unless explicitly requested.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Fri, 27 Dec 2013 14:28:57 +0000
+
+catacomb (2.1.5) experimental; urgency=low
+
+  * New build system.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Mon, 29 Jun 2013 00:38:58 +0100
+
+catacomb (2.1.4) experimental; urgency=low
+
+  * Constant-time operations.
+  * Some minor fixes to header files.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Mon, 27 May 2013 22:34:23 +0100
+
 catacomb (2.1.3) experimental; urgency=low
 
   * Fibonacci sequence computation: mp_fibonacci function and fibonacci(1)