build: Switch to using the new subtree version of CFD.
[catacomb] / debian / rules
index da79b9e..9c783b7 100755 (executable)
@@ -1,7 +1,12 @@
 #! /usr/bin/make -f
+DH_OPTIONS = --parallel -Bdebian/build
+%:; dh $@ $(DH_OPTIONS)
 
-CDBS = /usr/share/cdbs/1
-include $(CDBS)/rules/debhelper.mk
-include $(CDBS)/class/autotools.mk
+## Test both with and without CPU-specific optimizations.
+override_dh_auto_test:
+       dh_auto_test $(addprefix -O, $(DH_OPTIONS))
+       CATACOMB_CPUFEAT="-*" dh_auto_test $(addprefix -O, $(DH_OPTIONS))
 
-DEB_BUILDDIR = build
+## Check that the shared-library symbols are plausible.
+override_dh_makeshlibs:
+       dh_makeshlibs -- -c4