Merge branch '2.3.x'
[catacomb] / debian / changelog
index 7c457f6..024c3a7 100644 (file)
@@ -1,3 +1,77 @@
+catacomb (2.4.0.1) experimental; urgency=low
+
+  * Fix build failure with later ARM assemblers.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 21:05:35 +0100
+
+catacomb (2.4.0) experimental; urgency=low
+
+  * catacomb2: Implemented Bernstein's Poly1305 message-authentication
+    code.
+  * catacomb2: Support RFC7539's different nonce/counter split in ChaCha
+    and Salsa20.
+  * catacomb2: Implement Bernstein's X25519.
+  * catacomb2: Implement Hamburg's X448 (RFC7748).
+  * catacomb2: Implement Bernstein, Duif, Lange, Schwabe, Yang's Ed25519,
+    as defined in RFC8032.
+  * catacomb2: Implement Ed448, based on Hamburg's curve, as defined in
+    RFC8032.
+  * catacomb2: Implement Keccak-p[1600, n] as defined in FIPS202.
+  * catacomb2: Implement SHA3, SHAKE, as defined in FIPS202.
+  * catacomb2: Implement cSHAKE, KMAC, as defined in SP800-185.
+  * catacomb2: Allow RSA key generation with chosen public exponent.
+  * catacomb2: Optimize RSA public-key operations with common public
+    exponents.
+  * catacomb-bin: Support new algorithms in the provided tools.
+  * catacomb-bin: Allow parameters keys for all key types.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 16:07:00 +0100
+
+catacomb (2.3.2) experimental; urgency=low
+
+  * catacomb2: Fix bignum loading and storing in two's complement form.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Thu, 22 Jun 2017 09:34:59 +0100
+
+catacomb (2.3.1) experimental; urgency=low
+
+  * catacomb2: Fix memory corruption when allocating `salsa20' and
+    `chacha'-based RNGs.
+  * catacomb2: Fix segfault when opening read-only keyring with no
+    associated file.
+  * catacomb2: Return the correct stream offset in `chacha_tell*'.
+  * catacomb2: Produce correct keyring files when they contain empty
+    keys.
+  * catacomb2: Fix cross-compilation-unit type incompatibility in prime
+    and binary group implementations.
+  * catacomb-dev: Add missing licence notices to `salsa20.h'.
+  * catacomb-bin: Fix assertion failure in RSA-PSS signing.
+  * catacomb-bin: Fix uninitialized structure slot in RSA-PSS signing and
+    verifying.
+  * catacomb-bin: Compare MAC tags in constant time.
+  * catacomb2: Fix a (minor) source of bias in BBS and RSA key generation.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 04:05:00 +0100
+
+catacomb (2.3.0.1) experimental; urgency=low
+
+  * catacomb2: Actually make the stack non-executable rather than just
+    pretending.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Wed, 05 Apr 2017 09:00:55 +0100
+
+catacomb (2.3.0) experimental; urgency=low
+
+  * catacomb2: Use the correct Oakley 2048 group.  For a long time, this
+    was a duplicate of the Oakley 1536 group.  There's a compatibility
+    break here, but it's for the best.
+  * catacomb2: Include `.note.GNU-stack' sections in the assembler code,
+    so that the process stack doesn't get marked executable.
+  * catacomb2: New SSE2-based multipliers for i386 and AMD64.
+  * catacomb2: Lots of other improvements to the assembler code.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Mon, 03 Apr 2017 10:24:17 +0100
+
 catacomb (2.2.5) experimental; urgency=low
 
   * catacomb2 (ARM AES): Fix crash from `rijndael*_init' when key material