prime generation: Deploy the new Baillie--PSW testers.
[catacomb] / debian / rules
index 0c0cde0..9c783b7 100755 (executable)
@@ -1,8 +1,12 @@
 #! /usr/bin/make -f
+DH_OPTIONS = --parallel -Bdebian/build
+%:; dh $@ $(DH_OPTIONS)
 
-DH_OPTIONS = -Bdebian/build
-%:; dh $@ $(DH_OPTIONS) --without autoreconf
+## Test both with and without CPU-specific optimizations.
+override_dh_auto_test:
+       dh_auto_test $(addprefix -O, $(DH_OPTIONS))
+       CATACOMB_CPUFEAT="-*" dh_auto_test $(addprefix -O, $(DH_OPTIONS))
 
-override_dh_auto_install:
-       dh_auto_install $(addprefix -O,$(DH_OPTIONS))
-       rm -f debian/cfd/usr/share/info/dir
+## Check that the shared-library symbols are plausible.
+override_dh_makeshlibs:
+       dh_makeshlibs -- -c4