math/Makefile.am, symm/Makefile.am: Use `--no-install' on oddball tests.
[catacomb] / debian / changelog
index 9784b9e..8ac80a4 100644 (file)
@@ -1,3 +1,161 @@
+catacomb (2.4.4) experimental; urgency=medium
+
+  * debian: Bump to Debhelper 10.
+  * debian: Ship a shared-library `symbols' file for more precise
+    dependencies.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sun, 29 Sep 2019 15:58:26 +0100
+
+catacomb (2.4.3) experimental; urgency=medium
+
+  * catacomb (idea): Fix key-length descriptor.
+  * catacomb (xchachaNN): Fix nonce-size descriptor.
+  * catacomb (key-management): Fix incorrect handling of keyring
+    modifiability.
+  * catacomb-dev: Configure `pkg-config' correctly for static linking.
+  * catacomb, catacomb-bin (cookie, dsig): Fix hash-function length
+    padding on very long messages, and handling of large datestamps.
+  * catacomb-bin (catsign): Don't open temporary files unnecessarily.
+  * catacomb-bin (catcrypt): Fix key-attribute parsing.
+  * catacomb-bin (perftest): Add missing help-string text for `-n' used
+    with `enc' and `hash'
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sat, 21 Sep 2019 17:43:59 +0100
+
+catacomb (2.4.2) experimental; urgency=medium
+
+  * catacomb2: Support multi-arch at last.
+  * catacomb2: Fix mangled key-size data for HMAC.
+  * rspit: Support generating large files.
+  * pixie: Improve error-handling around dropping privilege.
+  * ed25519, ed448: Very minor performance improvement.
+  * salsa20, chacha: Fix crash if nonce is none, as it is when invoked by
+    `rspit'.
+  * salsa20, chacha: Fix declaration of cipher classes to prevent them
+    ending up as (useless) common symbols in client code.
+  * limlee: Improve the prime size heuristics.
+  * sha, sha256, sha512: Restructure compression function to improve
+    performance and use less memory.
+  * rijndael: Include enough round constants to make very tiny keys work
+    correctly.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Tue, 12 Jun 2018 01:15:59 +0100
+
+catacomb (2.4.1) experimental; urgency=low
+
+  * catacomb2: Two's-complement fix from 2.3.x release branch.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Thu, 22 Jun 2017 09:37:40 +0100
+
+catacomb (2.4.0.1) experimental; urgency=low
+
+  * Fix build failure with later ARM assemblers.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 21:05:35 +0100
+
+catacomb (2.4.0) experimental; urgency=low
+
+  * catacomb2: Implemented Bernstein's Poly1305 message-authentication
+    code.
+  * catacomb2: Support RFC7539's different nonce/counter split in ChaCha
+    and Salsa20.
+  * catacomb2: Implement Bernstein's X25519.
+  * catacomb2: Implement Hamburg's X448 (RFC7748).
+  * catacomb2: Implement Bernstein, Duif, Lange, Schwabe, Yang's Ed25519,
+    as defined in RFC8032.
+  * catacomb2: Implement Ed448, based on Hamburg's curve, as defined in
+    RFC8032.
+  * catacomb2: Implement Keccak-p[1600, n] as defined in FIPS202.
+  * catacomb2: Implement SHA3, SHAKE, as defined in FIPS202.
+  * catacomb2: Implement cSHAKE, KMAC, as defined in SP800-185.
+  * catacomb2: Allow RSA key generation with chosen public exponent.
+  * catacomb2: Optimize RSA public-key operations with common public
+    exponents.
+  * catacomb-bin: Support new algorithms in the provided tools.
+  * catacomb-bin: Allow parameters keys for all key types.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 16:07:00 +0100
+
+catacomb (2.3.2) experimental; urgency=low
+
+  * catacomb2: Fix bignum loading and storing in two's complement form.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Thu, 22 Jun 2017 09:34:59 +0100
+
+catacomb (2.3.1) experimental; urgency=low
+
+  * catacomb2: Fix memory corruption when allocating `salsa20' and
+    `chacha'-based RNGs.
+  * catacomb2: Fix segfault when opening read-only keyring with no
+    associated file.
+  * catacomb2: Return the correct stream offset in `chacha_tell*'.
+  * catacomb2: Produce correct keyring files when they contain empty
+    keys.
+  * catacomb2: Fix cross-compilation-unit type incompatibility in prime
+    and binary group implementations.
+  * catacomb-dev: Add missing licence notices to `salsa20.h'.
+  * catacomb-bin: Fix assertion failure in RSA-PSS signing.
+  * catacomb-bin: Fix uninitialized structure slot in RSA-PSS signing and
+    verifying.
+  * catacomb-bin: Compare MAC tags in constant time.
+  * catacomb2: Fix a (minor) source of bias in BBS and RSA key generation.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 04:05:00 +0100
+
+catacomb (2.3.0.1) experimental; urgency=low
+
+  * catacomb2: Actually make the stack non-executable rather than just
+    pretending.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Wed, 05 Apr 2017 09:00:55 +0100
+
+catacomb (2.3.0) experimental; urgency=low
+
+  * catacomb2: Use the correct Oakley 2048 group.  For a long time, this
+    was a duplicate of the Oakley 1536 group.  There's a compatibility
+    break here, but it's for the best.
+  * catacomb2: Include `.note.GNU-stack' sections in the assembler code,
+    so that the process stack doesn't get marked executable.
+  * catacomb2: New SSE2-based multipliers for i386 and AMD64.
+  * catacomb2: Lots of other improvements to the assembler code.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Mon, 03 Apr 2017 10:24:17 +0100
+
+catacomb (2.2.5) experimental; urgency=low
+
+  * catacomb2 (ARM AES): Fix crash from `rijndael*_init' when key material
+    is unaligned.
+  * build: Use less obsolete macro names in configure script.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Tue, 12 Jul 2016 10:27:05 +0100
+
+catacomb (2.2.4) experimental; urgency=low
+
+  * build: Fix build failures on post-wheezy Debian versions.
+  * catacomb2: Use ARM AES instructions if available.  (But they can't be
+    assembled using wheezy's version of gas, so this doesn't work in the
+    binary package.)
+  * catacomb2: Fix poor performance (and wrong answers for very small
+    numbers) in prime generation.
+  * catacomb2: Return numbers of exactly the requested length in prime and
+    public-key generation.  The `strongprime' and `limlee' algorithms have
+    changed as a result; previously verifiable parameters generated using
+    this algorithm won't be verifiable any more.
+  * catacomb-dev: Deprecate the old `dsa' functions.  Use `gdsa' instead.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sun, 26 Jun 2016 14:18:14 +0100
+
+catacomb (2.2.3) experimental; urgency=low
+
+  * rand: Make the main generator resiliant in the face of fork(2).
+  * rand: Introduce `rand_quick', which may also mix in CPU-level
+    randomness sources.
+  * rand: Use higher-resolution timer in the quick-win noise source.
+  * debian: Pick up correct `catacomb-dev' Depends entry from 2.2.1.1
+    which got lost down the side of the sofas.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Mon, 13 Jun 2016 22:22:33 +0100
+
 catacomb (2.2.2) experimental; urgency=low
 
   * build: Cope with newer Autotools and related equipment.
@@ -8,6 +166,13 @@ catacomb (2.2.2) experimental; urgency=low
 
  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 04 Jun 2016 01:12:01 +0100
 
+catacomb (2.2.1.1) experimental; urgency=low
+
+  * Arrange that catacomb-dev Depends on correct version of mlib-dev.  It
+    really won't work well without it.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Fri, 19 Feb 2016 09:04:50 +0000
+
 catacomb (2.2.1) experimental; urgency=low
 
   * Some internal improvements.