math/Makefile.am, symm/Makefile.am: Use `--no-install' on oddball tests.
[catacomb] / debian / rules
index d93449a..3fb55de 100755 (executable)
@@ -1,7 +1,12 @@
 #! /usr/bin/make -f
-%:; dh $@ --parallel -Bdebian/build
+DH_OPTIONS = --parallel --without=autoreconf -Bdebian/build
+%:; dh $@ $(DH_OPTIONS)
 
 ## Test both with and without CPU-specific optimizations.
 override_dh_auto_test:
-       dh_auto_test --parallel -Bdebian/build
-       CATACOMB_CPUFEAT="-*" dh_auto_test --parallel -Bdebian/build
+       dh_auto_test $(addprefix -O, $(DH_OPTIONS))
+       CATACOMB_CPUFEAT="-*" dh_auto_test $(addprefix -O, $(DH_OPTIONS))
+
+## Check that the shared-library symbols are plausible.
+override_dh_makeshlibs:
+       dh_makeshlibs -- -c4