base/asm-common.h: Add register-name conversions for ARM64 registers.
[catacomb] / debian / rules
index 21eca79..9c783b7 100755 (executable)
@@ -1,10 +1,12 @@
 #! /usr/bin/make -f
+DH_OPTIONS = --parallel -Bdebian/build
+%:; dh $@ $(DH_OPTIONS)
 
-CDBS = /usr/share/cdbs/1
-include $(CDBS)/rules/debhelper.mk
-include $(CDBS)/class/autotools.mk
+## Test both with and without CPU-specific optimizations.
+override_dh_auto_test:
+       dh_auto_test $(addprefix -O, $(DH_OPTIONS))
+       CATACOMB_CPUFEAT="-*" dh_auto_test $(addprefix -O, $(DH_OPTIONS))
 
-DEB_BUILDDIR = build
-
-install/cfd::
-       rm -f debian/cfd/usr/share/info/dir
+## Check that the shared-library symbols are plausible.
+override_dh_makeshlibs:
+       dh_makeshlibs -- -c4