Release 1.3.0.
[catacomb-python] / debian / changelog
index aaee0c3..80f422c 100644 (file)
@@ -1,3 +1,19 @@
+catacomb-python (1.3.0) experimental; urgency=medium
+
+  * catacomb: Bindings for new blockcipher-based MACs, and AEAD schemes.
+  * catacomb: Invalidate `grand' objects passed into Python through prime-
+    generation events.
+  * catacomb: Improve class docstrings.  (They're still extremely terse.)
+  * catacomb: Add missing `copy' methods on hash and Keccak objects.
+  * catacomb: Add `WriteBuffer.contents' as a more convenient way to
+    extract the contents than coercing to `str' or `ByteString'.
+  * catacomb: Set `RTLD_DEEPBIND' while loading the native module to work
+    around #868366.
+  * pock: New program for generating efficiently verifiable prime numbers,
+    and for verifying their certificates.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sat, 21 Sep 2019 23:00:25 +0100
+
 catacomb-python (1.2.1) experimental; urgency=low
 
   * Fix use-after-free bug in ECPt hashing causing hash instability.