group.c: Fix capitalization of `ECPt' in docstring.
[catacomb-python] / debian / changelog
index 7f5abd2..ca06b5c 100644 (file)
@@ -1,3 +1,32 @@
+catacomb-python (1.2.1.1) experimental; urgency=medium
+
+  * Fixing to build against Debian `stretch'.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Mon, 24 Dec 2018 15:21:08 +0000
+
+catacomb-python (1.2.1) experimental; urgency=low
+
+  * Fix use-after-free bug in ECPt hashing causing hash instability.
+  * Fix keywrd argument mismatch in ECDSAPriv.
+  * Coerce DSA private key values to `MP'.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Fri, 16 Jun 2017 01:01:05 +0100
+
+catacomb-python (1.2.0) experimental; urgency=low
+
+  * Bindings for HSalsa20 and HChaCha PRFs.
+  * Bindings for Poly1305.
+  * Bindings for X25519.
+  * Bindings for X448.
+  * Bindings for Ed25519.
+  * Bindings for Ed448.
+  * Bindings for Keccak[1600, n].
+  * Bindings for cSHAKE; Python implementation of KMAC.
+  * Improved pretty-printing for IPython.
+  * Allow selection of public exponent when generating RSA keys.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 17:29:53 +0100
+
 catacomb-python (1.1.2) experimental; urgency=low
 
   * Further 64-bit compatibility improvements.