Merge branch '1.3.x'
[catacomb-python] / debian / changelog
index 7f5abd2..66c14f7 100644 (file)
@@ -1,3 +1,61 @@
+catacomb-python (1.3.99~) experimental; urgency=medium
+
+  * (placeholder for next release)
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Tue, 01 Oct 2019 12:57:58 +0100
+
+catacomb-python (1.3.0.1) experimental; urgency=medium
+
+  * Fix required Catacomb version in `setup.py' script.  Only affects the
+    source package.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sun, 22 Sep 2019 01:21:28 +0100
+
+catacomb-python (1.3.0) experimental; urgency=medium
+
+  * catacomb: Bindings for new blockcipher-based MACs, and AEAD schemes.
+  * catacomb: Invalidate `grand' objects passed into Python through prime-
+    generation events.
+  * catacomb: Improve class docstrings.  (They're still extremely terse.)
+  * catacomb: Add missing `copy' methods on hash and Keccak objects.
+  * catacomb: Add `WriteBuffer.contents' as a more convenient way to
+    extract the contents than coercing to `str' or `ByteString'.
+  * catacomb: Set `RTLD_DEEPBIND' while loading the native module to work
+    around #868366.
+  * pock: New program for generating efficiently verifiable prime numbers,
+    and for verifying their certificates.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sat, 21 Sep 2019 23:00:25 +0100
+
+catacomb-python (1.2.1.1) experimental; urgency=medium
+
+  * Fixing to build against Debian `stretch'.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Mon, 24 Dec 2018 15:21:08 +0000
+
+catacomb-python (1.2.1) experimental; urgency=low
+
+  * Fix use-after-free bug in ECPt hashing causing hash instability.
+  * Fix keywrd argument mismatch in ECDSAPriv.
+  * Coerce DSA private key values to `MP'.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Fri, 16 Jun 2017 01:01:05 +0100
+
+catacomb-python (1.2.0) experimental; urgency=low
+
+  * Bindings for HSalsa20 and HChaCha PRFs.
+  * Bindings for Poly1305.
+  * Bindings for X25519.
+  * Bindings for X448.
+  * Bindings for Ed25519.
+  * Bindings for Ed448.
+  * Bindings for Keccak[1600, n].
+  * Bindings for cSHAKE; Python implementation of KMAC.
+  * Improved pretty-printing for IPython.
+  * Allow selection of public exponent when generating RSA keys.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 17:29:53 +0100
+
 catacomb-python (1.1.2) experimental; urgency=low
 
   * Further 64-bit compatibility improvements.