Port to Python 3.
[catacomb-python] / debian / rules
index 04d6f4e..fea60f6 100755 (executable)
@@ -1,10 +1,13 @@
 #! /usr/bin/make -f
-%:; dh $@ --parallel --with python2
+%:; dh $@ --parallel --with python2,python3
 
-export PYTHONS := $(shell pyversions -r)
+export PYTHON := $(shell pyversions -d)
+export PYTHONS := $(shell pyversions -r && py3versions -r)
 
 override_dh_auto_test:
        dh_auto_test -- OPTS-check=-V
 
 override_dh_auto_install:
-       dh_auto_install -- prefix=/usr
+       dh_auto_install -- prefix=/usr \
+               $(foreach p,$(filter-out $(PYTHON),$(PYTHONS)), \
+                       OPTS-install/$p="--install-scripts=/usr/bin-$p")