Merge branch '1.3.x'
[catacomb-python] / debian / changelog
index 537f1c9..66c14f7 100644 (file)
@@ -1,3 +1,123 @@
+catacomb-python (1.3.99~) experimental; urgency=medium
+
+  * (placeholder for next release)
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Tue, 01 Oct 2019 12:57:58 +0100
+
+catacomb-python (1.3.0.1) experimental; urgency=medium
+
+  * Fix required Catacomb version in `setup.py' script.  Only affects the
+    source package.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sun, 22 Sep 2019 01:21:28 +0100
+
+catacomb-python (1.3.0) experimental; urgency=medium
+
+  * catacomb: Bindings for new blockcipher-based MACs, and AEAD schemes.
+  * catacomb: Invalidate `grand' objects passed into Python through prime-
+    generation events.
+  * catacomb: Improve class docstrings.  (They're still extremely terse.)
+  * catacomb: Add missing `copy' methods on hash and Keccak objects.
+  * catacomb: Add `WriteBuffer.contents' as a more convenient way to
+    extract the contents than coercing to `str' or `ByteString'.
+  * catacomb: Set `RTLD_DEEPBIND' while loading the native module to work
+    around #868366.
+  * pock: New program for generating efficiently verifiable prime numbers,
+    and for verifying their certificates.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sat, 21 Sep 2019 23:00:25 +0100
+
+catacomb-python (1.2.1.1) experimental; urgency=medium
+
+  * Fixing to build against Debian `stretch'.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Mon, 24 Dec 2018 15:21:08 +0000
+
+catacomb-python (1.2.1) experimental; urgency=low
+
+  * Fix use-after-free bug in ECPt hashing causing hash instability.
+  * Fix keywrd argument mismatch in ECDSAPriv.
+  * Coerce DSA private key values to `MP'.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Fri, 16 Jun 2017 01:01:05 +0100
+
+catacomb-python (1.2.0) experimental; urgency=low
+
+  * Bindings for HSalsa20 and HChaCha PRFs.
+  * Bindings for Poly1305.
+  * Bindings for X25519.
+  * Bindings for X448.
+  * Bindings for Ed25519.
+  * Bindings for Ed448.
+  * Bindings for Keccak[1600, n].
+  * Bindings for cSHAKE; Python implementation of KMAC.
+  * Improved pretty-printing for IPython.
+  * Allow selection of public exponent when generating RSA keys.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 17:29:53 +0100
+
+catacomb-python (1.1.2) experimental; urgency=low
+
+  * Further 64-bit compatibility improvements.
+  * Fixed docstrings for a number of native methods.
+  * Fix range checking for `GRand' methods.
+  * Fix crash when deleting natively implemented object attributes.
+  * Fix bug which assigned the wrong hash to bytestrings.
+  * Fix `__int__' methods to return `long' objects when necessary.
+    Without this, there are unnecessary failures and bizarrely timed
+    exceptions.
+  * A couple of patches to provide forward compatibility with upstream
+    library changes.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 04:25:35 +0100
+
+catacomb-python (1.1.1) experimental; urgency=low
+
+  * ByteString operators: fix crashes on 64-bit platforms resulting from
+    the use of the wrong length types.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sat, 04 Jun 2016 01:17:14 +0100
+
+catacomb-python (1.1.0.1) experimental; urgency=low
+
+  * Just Debian packaging fixes.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Fri, 19 Feb 2016 19:39:28 +0000
+
+catacomb-python (1.1.0) experimental; urgency=low
+
+  * Fix crash on trying to import RSA public and private keys with even
+    modulus.
+  * Add bindings for key-strength conversion functions.
+  * Add bindings for factorial and Fibonacci calculations.
+  * Implement exact field-of-fractions arithmetic for integers and binary
+    polynomials.
+  * Set module nameson types properly, so that IPython doesn't choke on
+    printing them.
+  * Implement hashing for comparable types.  Again, this makes IPython
+    work better.
+  * Support Daniel Bernstein's Salsa20 and ChaCha stream ciphers.
+  * Stop abusing SyntaxError.
+  * Support elliptic curve point compression formats.
+  * Major overhaul of the `pwsafe' utility: multiple storage backends, so
+    (a) we no longer require GDBM, and (b) we can use a Git-friendly
+    directory-based format.  Or SQLite.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Mon, 20 Jul 2015 16:07:51 +0100
+
+catacomb-python (1.0.6) experimental; urgency=low
+
+  * Fix stupid bug in WriteBuffer resizing.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sun, 21 Jul 2013 15:57:06 +0100
+
+catacomb-python (1.0.5) experimental; urgency=low
+
+  * Make Key constructor actually work.
+  * Include human-readable text in KeyError exceptions.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sat, 04 Jan 2014 01:38:26 +0000
+
 catacomb-python (1.0.4) experimental; urgency=low
 
   * Build against Python 2.7.