algorithms.c: Use `RETURN_ME' rather than doing the job by hand.
[catacomb-python] / debian / control
index 6930e6e..2957d2e 100644 (file)
@@ -1,16 +1,20 @@
 Source: catacomb-python
 Section: python
 Priority: extra
-XS-Python-Version: >= 2.4, << 2.7
+XS-Python-Version: >= 2.6, << 2.8
+XS-Python3-Version: >= 3.0
 Maintainer: Mark Wooding <mdw@distorted.org.uk>
-Build-Depends: catacomb-dev, python, python2.4-dev, python2.5-dev
+Build-Depends: debhelper (>= 10), dh-python, pkg-config,
+       python (>= 2.6.6-3~), python-all-dev, python3-all-dev,
+       mlib-dev (>= 2.4.99~), catacomb-dev (>= 2.5.0)
 Standards-Version: 3.8.0
 
 Package: python-catacomb
 Architecture: any
 XB-Python-Version: ${python:Versions}
 Depends: ${shlibs:Depends}, ${python:Depends}
-Provides: python2.4-catacomb, python2.5-catacomb, python2.6-catacomb
+Provides: ${python:Provides}, catacomb-python-bin
+Conflicts: catacomb-python-bin
 Description: Python bindings for the Catacomb cryptographic library.
  Catacomb is a cryptographic library.  It implements a large number of
  encryption algorithms, hash functions, message authentication codes
@@ -22,14 +26,14 @@ Description: Python bindings for the Catacomb cryptographic library.
  relatively straightforward to audit for security.  Its focus is on
  clarity of source code and portability more than performance.
  .
- This is a dummy package for making sure you have the right package
- for the default Debian Python installation.
+ This package allows the Catacomb library to be used in Python programs.
 
-Package: python-catacomb-bin
-Architecture: all
-XB-Python-Version: ${python:Versions}
-Depends: python, python-catacomb
-Description: Catacomb utilities in Python
+Package: python3-catacomb
+Architecture: any
+XB-Python-Version: ${python3:Versions}
+Depends: ${shlibs:Depends}, ${python3:Depends}
+Provides: ${python3:Provides}
+Description: Python 3 bindings for the Catacomb cryptographic library.
  Catacomb is a cryptographic library.  It implements a large number of
  encryption algorithms, hash functions, message authentication codes
  and random number generators.  It has a multi-precision maths library,
@@ -40,4 +44,4 @@ Description: Catacomb utilities in Python
  relatively straightforward to audit for security.  Its focus is on
  clarity of source code and portability more than performance.
  .
- This package contains Catacomb-related utilities written in Python.
+ This package allows the Catacomb library to be used in Python 3 programs.