cleanup: Big pile of whitespace fixes, all at once.
[u/mdw/catacomb] / debian / catacomb-bin.postinst
1 #! /bin/sh -e
2 . /usr/share/debconf/confmodule
3 db_version 2.0
4 db_get catacomb-bin/pixie-is-setuid; setuid=$RET
5 dpkg-statoverride --remove /usr/bin/pixie 2>/dev/null || true
6 case $setuid in
7 true)
8 echo "Installing /usr/bin/pixie setuid-root."
9 dpkg-statoverride --add --update root root 4755 /usr/bin/pixie
10 ;;
11 false)
12 echo "Making /usr/bin/pixie non-setuid."
13 dpkg-statoverride --add --update root root 755 /usr/bin/pixie
14 ;;
15 esac
16
17 #DEBHELPER#